
The OptiSage module

Use the OptiSage module for the assessment of Gibbs energy data.
Various types of experimental data can be utilized in order to generate optimized parameters for 
the Gibbs energies of stoichiometric compounds as well as the excess coefficients of a wide 
range of non-ideal solution models.

In the present example we will use OptiSage to treat the various phase diagram, enthalpy and 
activity data for the NaCl-SrCl2 system in order to obtain polynomial parameters for the Gibbs 
energy of mixing in the liquid phase.
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Introduction to the Data Optimization procedure

The OptiSage module is used to generate  a consistent set of Gibbs energy 
parameters from a given set of experimental data using known Gibbs energy 
data from well established phases of a particular chemical system.

Typical experimental data include:

– phase diagram data: transition temperatures and pressures as well as amount 
and composition of the phases at equilibrium

– calorimetric data: enthalpies of formation or phase transformation, enthalpies 
of mixing, heat contents and heat capacity measurements
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of mixing, heat contents and heat capacity measurements

– partial Gibbs energy data: activities from vapor pressure or EMF 
measurements

– volumetric data: dilatometry, density measurements.

The assessor (user of OptiSage) has to use his best judgement on which of 
the known parameters should remain fixed, which set of parameters need 
refinement in the optimization and which new parameters have to be 
introduced, especially when assessing data for non-ideal solutions.
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Overview of the data to be optimized in the NaCl-SrCl2 system

Various experimental data on the binary NaCl-SrCl2 system are available:

– phase diagram data (liquidus points, eutectic points)

– liquid-liquid enthalpy of mixing (at 894°C)

– activity of NaCl(liq) at 3 different temperatures (800°C, 825°C and 850°C)

OptiSage will be used to optimize the parameters for the liquid  interctions (GE terms). 
All other data (G°of the pure stoichiometric solids, as w ell as the pure liquid 
components) will be taken from the FACT database (i.e. remain fixed). 
A substitutional solution model with a polynomial for the excess Gibbs energy will be 
used:                G = (X1 G°1 + X2 G°2) + RT(X1 ln X1 + X2 ln X2) + GE
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used:                G = (X1 G°1 + X2 G°2) + RT(X1 ln X1 + X2 ln X2) + GE

where GE = ∆H – TSE

Using the binary excess terms:
∆H = X1X2 (A1) + X1

2X2 (A2)
-SE = X1X2 (B1) + X1

2X2 (B2)
one obtains: 
GE = X1X2 (A1 + B1T) + X1

2X2 (A2 + B2T)
Where A1, A2, B1 and B2 are the 4 
parameters to be optimized. SrCl2XSrCl2

G

NaCl

G°1

G°2
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The 3 Steps in the Optimization Procedure

In general a three step procedure is adopted for the optimization:

Step 1.  Set a thermodynamic datafile (ChemSage file)

Step 2.  Organise the various experimental data values (Excel file)

OptiSage
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Step 3.  Execute the optimization program interactively (run OptiSage)

In order to create a ChemSage file (step 1.), it is necessary to use the 
Compound, Solution and Equilib modules as outlined in the following 
slides. 
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Creation of a private (r/w) compound database

• OptiSage uses a ChemSage thermodynamic datafile containing all known and 
unknown (to be optimized) model parameters. The ChemSage file is created by 
Equilib.

• G°of each component of the liquid phase is taken from t he FACT database.

Component Index G°

NaCl 1 Liquid from FACT
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SrCl2 2 Liquid from FACT

• You have to create a private r/w (read/write) COMPOUND database containing 
NaCl(liq) and SrCl2(liq) using the Compound module. Public data (read-only) 
cannot be used in OptiSage.

• To create a private Compound database: see Compound section 3.
• To transfer data between databases: see Compound section 11.
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Private Compound Database

A private Compound database nicknamed USER containing NaCl and 
SrCl2 should look like:
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Note: Gaseous NaCl and SrCl2 are not needed in the present example.
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Creation of a new solution database

• You have to create a private solution file containing all parameters  (either 
known and/or to be optimized) for each solution phase to be optimized. 
You cannot perform an optimization using a public database (read-only) 
such as FACT.

• The solution file must include all parameters to be optimized (with their 
coefficients set to zero or to any initial value).

• For the NaCl-SrCl2 system:
– one phase is to be optimized: the liquid solution.
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– one phase is to be optimized: the liquid solution.
– a polynomial model will be used (see slide 3).

4 coefficients are set to zero:
i.e. A1 = A2 = B1 = B2 = 0

• A solution database nicknamed SOLUTION has been created using the 
Solution module.
– to create a private solution database: see Solution section 5 .

• Save this solution file.
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Private Solution Database

Nickname of the liquid solution

In the Solution module, a new private solution 
database named SOLUTION.dat should look like:

Polynomial ModelName of the liquid solution
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Excess parameters (i.e. A1, A2, B1 and B2) are set to 0

Polynomial Model
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Generation of a ChemSage file

The following four slides show how the above Compound and 
Solution private databases are linked with the Equilib module, and 
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Solution private databases are linked with the Equilib module, and 
how the selection of the relevant phases in Equilib is used to 
generate the ChemSage file.
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Creation of a ChemSage file for the optimization

The procedure is:
– open the Equilib module
– enter the components NaCl and SrCl2 in the Reactants window of Equilib
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Adding your private databases to FactSage list of databases

Do not forget to add and activate the newly created private databases to the list of databases in 
the Equilib module (see Equilib Advanced slide 26.3 and Phase Diagram slide 6.1). 
From the Menu Bar in the Reactants-Equilib window, select: Data Search

Make sure that the ELEM compound 
database is also selected and that no
other databases are selected.
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…and add your 
read and write (r/w)

databases
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Equilib Menu window

– in the Menu window of Equilib, select all the species and the solutions 
(including the solution(s) to be optimized) involved in the actual 
optimization from your USER databases.

– save a ChemSage (ASCII format *.dat) file.
In the menu bar, select File > ChemSage file > Save ChemSage file… 
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Saving a ChemSage File

Saving an ASCII ChemSage file (*.dat) under the name :
NaCl_SrCl2.dat
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Experimental datasets to be used in the optimization

Step 2: Organize the experimental data.

Various types of experimental data can be used in an optimization.

In the present example activity data, enthalpies of mixing and phase 
diagram data will be employed. Each phase boundary will be treated as 
a separate dataset.
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a separate dataset.

The datasets will be given the names GROUP #1, #2, …, #5. This leads 
to five different datasets.

The following three slides show how the five different groups are 
defined.
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Group #1 – Experimental Data Points: Activity Data.

• We want to utilize the experimental data to obtain optimized model 
parameters for the NaCl-SrCl2 liquid phase.

• Data are divided into five different groups where each group corresponds 
to a specific type of Equilib calculation .

• Group #1:  Activity of NaCl in the liquid phase
– Experimental conditions:

• Amount of NaCl in the liquid 
phase Ostvold(850

o
C)0.9

1
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• Amount of SrCl 2 in the liquid 
phase 

• Temperature
• Pressure

– Measured variables:
• Activity of NaCl in the liquid 

phase 

– Selected phases:
• Liquid phase

5.1

Egan and Bracker(825
o
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Emons et al.(800
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Group #2 – Heat of mixing data

Group #2: Enthalpy of mixing of the NaCl-SrCl 2 liquid mixture 
at 1167K (894°C).

– Experimental conditions:
• Amount of NaCl(liquid)
• Amount of SrCl 2(liquid)
• Initial Temperature
• Initial Pressure
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• Initial Pressure
• Final Temperature
• Final Pressure

– Measured variables:
• Enthalpy of mixing (liquid)

– Selected phases:
• Liquid phase

5.2

Exp. Points of Ostvold (894oC)
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Groups #3, #4 and #5 – Data related to phase equilibria.

• Group #3:  Eutectic temperature
– Experimental conditions:

• Amount of NaCl in the liquid phase 
• Amount of SrCl 2 in the liquid phase 
• Pressure

– Measured variables:
• Temperature

(Formation Target on liquid)

– Selected phases:
• Liquid phase 
• NaCl(s)
• SrCl 2(s1)

• Group #5:  SrCl 2 liquidus data
– Experimental conditions:

• Amount of NaCl(s)
• Amount of SrCl 2(s1)
• Pressure

– Measured variables:
• Temperature

(Precipitation Target on liquid)

– Selected phases:
• Liquid phase 
• SrCl 2(s1)
• SrCl 2(s2)

o
900
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• Group #4:  NaCl liquidus data
– Experimental conditions:

• Amount of NaCl(s)
• Amount of SrCl 2(s1)
• Pressure

– Measured variables:
• Temperature

(Formation Target on NaCl(s))

– Selected phases:
• Liquid phase 
• NaCl(s)
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Experimental Data

The experimental data are stored in an Excel spreadsheet.    
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Executing the OptiSage module

Step 3.  Execute the optimization program interacti vely. 

When the thermodynamic datafile (ChemSage file) has been created  
(Step 1.) and the numerical values of the experimental data to be 
used in the optimization have been organised into groups (Step 2.), 
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used in the optimization have been organised into groups (Step 2.), 
the OptiSage module can be executed and the ChemSage file
loaded.

The following two slides show how to initiate OptiSage.

6.0



The OptiSage Module

• After creating :
– a compound database
– a solution database
– a ChemSage file

• and organising the 
experimental data 
into groups

• OptiSage is ready to 
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be employed
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OptiSage main window: New optimization

• Open a new optimization.
• Select File > New from the Menu bar 

or click on         from the toolbar to 
open a New optimization.

Then open your ChemSage file by selecting:
1. File > Open ChemSage File from the Menu 

bar, or
2. Thermodynamic File from the treeview and 

double-click to select an input ChemSage 
thermodynamic file.

www.factsage.comOptiSage 6.2



Creating OptiSage input for the experimental data

The thermodynamic data of the system are already stored. Since the 
thermodynamic datafile also contains the names of the phases and their 
constituents these names are also available in OptiSage.

The following eight slides show how the data for experimental Group #1, 
Activities of the components in the liquid phase at a given temperature, are 
entered into the calculation.
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NOTE: For all experimental input, there is a distinction made between the 
experimental conditions and the measured variables. In the 
present case, activities have been measured as function of 
temperature and composition. Thus temperature and composition 
(as well as total pressure) are experimental conditions and the 
measured activities are the measured variables. Different parts of 
the input window are used for these different data.
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Importing the data into Group #1

Open the ChemSage
file previously created. At this point, the OptiSage window 

shows the tree view (fully expanded) and 
we are ready to enter the experimental 
data that will be used in the optimization.
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A right-click on Experimental Data
opens the pop-up menu. Select <Add>
to open the ‘Add Group’ window.
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The Add Group window

Enter the description of 
group #1: Activity of 
NaCl in the liquid phase

Check «initial conditions » only when ∆H, ∆G, ∆V, ∆S or 
∆Cp are calculated. (ex: adiabatic T, ∆Hmix, etc…)

Select units
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A right-click in each 
spreadsheet opens a pop-up 
menu where you can add, 
edit, delete, load from a file,  
save to a file either the 
Experimental Conditions
or the Measured Variable(s)
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Adding new Experimental Conditions

• Group #1:  Activity of NaCl in the 
liquid phase

1. Experimental conditions :
1. Amount of NaCl in the liquid phase 
2. Amount of SrCl 2 in the liquid phase 
3. Temperature
4. Pressure

2. Measured variables:
1. Activity of NaCl in the liquid phase

P moles moles T activity error
SrCl2 NaCl K NaCl (estimated at 1%)

atm liquid liquid liquid
1 0.2 0.8 1073.15 0.777 0.00777
1 0.3 0.7 1073.15 0.659 0.00659
1 0.4 0.6 1073.15 0.533 0.00533
1 0.9 0.1 1098 0.0808 0.000808
1 0.8 0.2 1098 0.162 0.00162
1 0.5 0.5 1098 0.454 0.00454
1 0.3 0.7 1098 0.682 0.00682
1 0.401 0.599 1123 0.5437 0.005437
1 0.6 0.4 1123 0.3381 0.003381
1 0.799 0.201 1123 0.1593 0.001593
1 0.46 0.54 1123 0.53 0.0053

Activity of NaCl in the liquid phase
Experimental conditions Measured variable
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1. Right-click in the Experimental 
Conditions spreadsheet and select 
Add variable… from the pop-up 
menu or click on the        button in the 
menu bar to open the Add 
Experimental Conditions window.

1. Activity of NaCl in the liquid phase

3. Selected phases:
1. Liquid phase 

2. Enter an experimental condition . For 
example, temperature , on a linear scale X . 

3. Click OK.

4. Repeat for the 3 other experimental conditions .

1 0.46 0.54 1123 0.53 0.0053
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The «Add Experimental Condition » Window

List of the experimental conditions you can declare.

List of scales available

List of the phases available 
(when the option is enabled)

Note: Choosing the experimental conditions is equivalent to 
entering reactants and fixing final conditions in Equilib.
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List of the phase constituents
available when needed.

List of streams (max. 20)
Enabled if the «initial conditions » checkbox in the unit frame of 
the Add Group window is checked and needed when there is 
any difference between the initial and the final conditions 
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Adding the 3 other experimental conditions of Group #1

Changing Units
Pressures are in bar and your data are in atm . Select the appropriate unit.
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Adding new Measured Variables

• Group #1:  Activity of NaCl in the liquid phase

1. Experimental conditions:
• Amount of NaCl in the liquid phase 
• Amount of SrCl 2 in the liquid phase 
• Temperature
• Pressure

P moles moles T activity error
SrCl2 NaCl K NaCl (estimated at 1%)

Activity of NaCl in the liquid phase
Experimental Conditions Measured Variable
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2. Measured variables:
Activity of NaCl in the liquid phase 

3. Selected phases:
Liquid phase 

SrCl2 NaCl K NaCl (estimated at 1%)
atm liquid liquid liquid

1 0.2 0.8 1073.15 0.777 0.00777
1 0.3 0.7 1073.15 0.659 0.00659
1 0.4 0.6 1073.15 0.533 0.00533
1 0.9 0.1 1098 0.0808 0.000808
1 0.8 0.2 1098 0.162 0.00162
1 0.5 0.5 1098 0.454 0.00454
1 0.3 0.7 1098 0.682 0.00682
1 0.401 0.599 1123 0.5437 0.005437
1 0.6 0.4 1123 0.3381 0.003381
1 0.799 0.201 1123 0.1593 0.001593
1 0.46 0.54 1123 0.53 0.0053
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Adding a Measured Variable

1. Right-click in the Measured Variable(s) spreadsheet and select Add variable… from the 
pop-up menu or click on the        button in the menu bar to open the Add Measured Variable
window.

2. Enter a measured variable .
Here, the activity 

of NaCl 
in the NaSrCl (liquid) phase 

on a linear scale X . 
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3. Click OK.

4. Repeat for the other measured
variables if necessary .
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The «Add Measured Variable » Window

List of the measured variables you can declare.

List of scales available

List of the phases
available (when the 
option is enabled)

www.factsage.comOptiSage

List of the phase 
constituents available 
when needed.

More are available for 
aqueous systems.

The Target frame is enabled if the 
final T (P or <A>) is not specified 
but generated by way of a Target 
calculation. See slide 7.22.
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Group #1: declaration of variables

The declaration of all variables is completed.
The «Add Group» window should look like: 

Each Measured Variables 
declaration creates 2 columns:

• One for the data
• One for the estimated error 

(positive absolute value)
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Import the data into Group #1

You can enter your data manually or, if your data are in a 
spreadsheet, copy and paste them in the «Add Group » window.

www.factsage.comOptiSage

1. Copy of 2 colums of data in 
EXCEL

2. Right-click in the first cell in 
OptiSage to select Paste .

Experimental or estimated error must be entered if date are to be considered in the 
optimization. If a cell is blank or has a value of zero the corresponding data will be ignored. 
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Group #1, Selection of the phases

1. Experimental conditions:
– Amount of NaCl in the liquid phase 
– Amount of SrCl 2 in the liquid 

phase 
– Temperature
– Pressure

2. Measured variables:
Activity of NaCl in the liquid phase 

3. Selected phases:
Liquid phase (NaSrCl)

By default, all phases are eliminated
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To select a phase:
1. Click on a phase in the Eliminated frame and
2. Drag it in the Entered(Stable) frame

This is equivalent to species 
selection in Equilib
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Saving experimental data and closing Group #1

To save data and return to the OptiSage main window, select File > Save and close

To select or unselect all points, use Edit > Select (or Unselect ) all points

Warning : Reset will clear all the entries in the Add Group #1 window
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To format the experimental data spreadsheet cells, 
use the pop-up menu (right-click in the spreadsheet)
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Importing the data into Group #2

A right-click on Experimental Data opens the pop-up menu. 
Select <Add> to open the ‘Add Group’ window.

Group #2: Enthalpy of mixing of the NaCl-SrCl 2 liquid mixture at 1167K (894°C).
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Group #2: Heat of mixing data

Enthalpy of mixing of the NaCl-SrCl 2 liquid mixture at 1167K (894°C)

1. Experimental conditions:
– Amount of NaCl(liquid)
– Amount of SrCl 2(liquid)
– Initial Temperature
– Initial Pressure
– Final Temperature
– Final Pressure

2. Measured variables:
– Enthalpy of mixing (liquid)

3. Selected phases:

Mixture of NaCl-SrCl2 (liquid)
T
P

∆∆∆∆Hmix

stream 1
NaCl (liquid)

T1
P1

stream 2
SrCl 2 (liquid)

T2
P2

Initial 
conditions

Final 
conditions
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3. Selected phases:
– Liquid phase (NaSrCl)

∆∆∆∆Hmix

Here,
P=P1=P2= 1 atm
T=T1=T2= 1167 K

conditions

P moles moles T H error
SrCl2 NaCl K J J

atm liquid liquid
1 0.095 0.905 1167 -490 50
1 0.204 0.796 1167 -845 50
1 0.294 0.706 1167 -962 50
1 0.412 0.588 1167 -996 50
1 0.498 0.502 1167 -962 50
1 0.608 0.392 1167 -703 50
1 0.704 0.296 1167 -510 50
1 0.904 0.096 1167 -269 50

Enthalpy of mixing in binary 
liquid mixture of NaCl-SrCl2 

at 1167K
Experimental Conditions Measured Variable
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Group #2: Declaration of Experimental Conditions

Experimental Conditions: • Amount of NaCl(liquid) • Final Pressure (P)

• Amount of SrCl 2(liquid) • Initial Temperature [ T1 , T2 ]

• Final Temperature (T) • Initial Pressure [ P1 , P2 ]

1. Enter a group description
2. Select the units
3. Check the initial conditions

4. Declare all Experimental Conditions
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Amount of 
NaCl(liquid)

Amount of 
SrCl 2(liquid)

(T) (P)

[ T1 ] [ T2 ] [ P1 ] [ P2 ]

(Final conditions)

[ Initial conditions ]
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Group #2: Declaration of the Measured Variable

1. Experimental conditions:
– Amount of NaCl(liquid)
– Amount of SrCl 2(liquid)
– Initial Temperature
– Initial Pressure
– Final Temperature
– Final Pressure

2. Measured variables:
– Enthalpy of mixing (liquid)

3. Selected phases:
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3. Selected phases:
– Liquid phase (NaSrCl)

Mixture of NaCl-SrCl2 (liquid)
T
P

∆∆∆∆Hmix

stream 1
NaCl (liquid)

T1
P1

stream 2
SrCl 2 (liquid)

T2
P2
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Group #2: Summary of the variables

The «Add Group #2» window when the declaration of all variables is finished °
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Please see slide 7.15 for the complete declaration of Experimental Conditions
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Import the experimental data into Group #2 window

All points selected

Finally, save data and return to the OptiSage main window, select File > Save and close
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Phase selection: Drag and drop from Dormant
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Importing data into Group #3

Group #3: Eutectic Temperature
A right-click on Experimental Data opens the pop-up menu. 
Select <Add> to open the ‘Add Group’ window.
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Group #3: Eutectic Temperature

1. Experimental conditions:
– Amount of NaCl(liquid)
– Amount of SrCl 2(liquid)
– Pressure

2. Measured variables:
– Temperature
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– Temperature
(used in Formation Target
for liquid phase (NaSrCl))

3. Selected phases:
– Liquid phase (NaSrCl)
– NaCl(s)
– SrCl2(s1)

P moles moles T(K) error
SrCl2 NaCl formation target (K)

atm liquid liquid liquid
1 0.5 0.5 838 2
1 0.4 0.6 837 2

Eutectic Temperature
Experimental Conditions Measured Variable
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Declaration and input of the Experimental Conditions

Group’s name entered, units selected
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We will select a formation target of the liquid phase 
for the eutectic temperature measurements

Experimental Conditions 
variables and data entered
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Measured variable: formation and precipitation target features

The Target frame is enabled 
because the final T is not specified. 1.Select the target type :

• Formation Target: The program calculates 
when this phase first forms (activity = 1, and 
normally zero mass). Note that one of T, P or 
alpha (<A>) must not be specified (i.e. blank) 
so that OptiSage can calculate the limiting T 
(P or <A>) when the formation target phase 
first forms. The formation target phase may 
be a compound species (for example a pure 
solid or liquid) or a solution phase (gas phase 
or real solution). (See also Equilib 
Advanced slides 3.1 to 3.6).
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Advanced slides 3.1 to 3.6).
• Precipitation Target: The program 

calculates when a second phase first starts 
to precipitate (activity = 1, zero mass) from 
this target solution phase (activity = 1, 100% 
mass).   Note that one of T, P or alpha (<A>) 
must not be specified (i.e. blank) so that 
OptiSage can calculate the limiting T (P or 
<A>) when the second phase precipitates. 
The precipitate target phase must be a 
solution phase. (See also Equilib Advanced
slides 3.7 to 3.11).  

2.Select the target phase

3.Press OK.
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Declaration and input of Measured Variable , phases’ selection

3. Finally, save data and return to the OptiSage main window, select File > Save and close

www.factsage.comOptiSage

2. Enter the data for the measured variables1. Select the phases
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Importing the data into Group #4

A right-click on Experimental Data opens the pop-up menu. 
Select <Add> to open the ‘Add Group’ window.

Group #4: NaCl Liquidus Data
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Group #4:  NaCl Liquidus Data

1. Experimental conditions:
– Amount of NaCl(s)
– Amount of SrCl 2(s1)
– Pressure

2. Measured variables:
Temperature
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– Temperature
(used in Formation Target
for NaCl(s))

3. Selected phases:
– Liquid phase (NaSrCl)
– NaCl(s)

P moles moles T(K) error
SrCl2 NaCl Formation Target (K)

atm liquid liquid NaCl(s)
1 0.146 0.854 1023 4
1 0.258 0.742 973 6
1 0.365 0.635 923 8
1 0.465 0.535 873 10

Experimental Conditions Measured Variable
NaCl Liquidus Data
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Metastable Phases (Filling the Add Group #4 window)

Do not forget to save your data (select File > Save and close )
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Dormant or Metastable phases
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Importing the data into Group #5

A right-click on Experimental Data opens the pop-up menu. 
Select <Add> to open the ‘Add Group’ window.

Group #5: SrCl 2 Liquidus Data
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Group #5:  SrCl 2 liquidus data

1. Experimental conditions:
– Amount of NaCl(s)
– Amount of SrCl 2(s1)
– Pressure

2. Measured variables:
– Temperature

(used in Precipitation Target for   
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(used in Precipitation Target for   
liquid phase (NaSrCl))

3. Selected phases:
– Liquid phase (NaSrCl)
– SrCl 2(s1)
– SrCl 2(s2)

P moles moles T(K) error
SrCl2 NaCl Precipitation Target (K)

atm liquid liquid liquid
1 0.97 0.03 1116 5
1 0.914 0.086 1082 5
1 0.86 0.14 1047 5
1 0.81 0.19 1013 5
1 0.762 0.238 985 5
1 0.68 0.32 933 5
1 0.6 0.4 882 5
1 0.513 0.487 843 5

SrCl2 Liquidus Data
Experimental Conditions Measured Variable
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Add Group #5 with data entered and phases selected

Do not forget to save your data.

This time, it is a 
precipitation target
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Creation of (Save as…) a FactSage optimization file

Your Experimental Data are saved in a default folder (FACT-51\OptIO\Default, in the present case). 
The next step is to create a FactSage optimization file. 
Select File > Save as… to open the Save Optimization File dialog box.
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Saving a FactSage optimization file

2. Enter the file name

1. Browse or create your own folder

Folder OptiSage_IO

www.factsage.comOptiSage

3. Save your optimization file (*.opt)

Note: You can save your file after adding a group of experimental data.

Warning:
You must save an optimization file 
before closing the application.
Failing to do that operation will 
result in the loss of your 
experimental data files.

Folder OptiSage_IO
created in FactSage

8.2



Location of your files

Your experimental data files 
and…
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You may now quit the application 
without losing any data.

… your optimization file 
are saved in the same folder.



Opening an OptiSage file

The next time you want to work on your optimization, 
just open your file in the OptiSage main window by:

clicking on the « Open OptiSage file » button or 
selecting the menu File > Open Optimization

…to open the « Open Optomizer file » window.
select your *.opt file and press Open
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Execution of an optimization

The actual execution of the optimization consists of several 
actions which a user has to go through one after the other.

– The parameters that shall be optimized have to be selected.

– Initial values for these parameters have to be entered and estimated 
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values for the errors of the parameters have to be defined.

– In some cases it is necessary to provide numerical relationships
between the parameters if they are not mathematically independent.

After that the optimization calculation can be started.

9.0



Selection of the phase to optimize

To select the phase to optimize, click on its 
name and the Solution (or phase component) 
panel appears.

In our example, we want to optimize the 
parameters of the liquid phase. Please 
review slide 2.2 where we define GE as 
GE = X1X2 (A1 + B1T) + X1

2X2 (A2 + B2T)
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Selection of the first set of parameters to optimize

Then click on the first set of parameters: 
X1X2 (A1 + B1T)

The parameters pane appears.
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The variable Yi is the equivalent molar fraction of component i. 
See Solution slide show, section 6 for more details.
In our example, Yi = Xi which is the molar fraction.
LO is a polynomial having the general form:
LO = A + BT + C(T lnT) + DT2 + ET3 + FT-1

In our example, LO has the form: LO = A + BT, where A and B
are the parameters to optimize.
Check the optimize check boxes for these two parame ters.



Selection of the second set of parameters to optimize
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The second set of parameters:
X1

2X2 (A2 + B2T)
is selected the same way as previously.



Parameters menu and edition of selected parameters

Clears your selection

Opens the Selected Parameters pane where you can edit:
• the initial value of a parameter
• the standard deviation (i.e. error) of a parameter
• the coupling state of a parameter
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It is imperative to select Parameters > Selected , even 
if you start with the default values (i.e. Initial Value = 0 , 
Std Dev = 100000 , coupling state = Non Coupled). 
This operation initializes your parameters and enables 
the functions Calculate > Optimize with… .

Note: The Coupled feature allows the user to provide numerical relationships between the 
parameters if they are not mathematically independent. It is an advanced feature of 
the Optisage module and will be demonstrated during FactSage workshops.



Initiating an optimization

From the menu bar, select Calculate > Optimize  
with Bayesian to start calculation of your first 
optimization using the Bayesian technique.
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Optimization results after 5 iterations

Result: No solution was obtained with only 5 iterations

So we close the OptiSage: Results window by selecting File > Close
without saving the results to return in the OptiSage main window.
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Options Features

Different options are available in OptiSage, you can select:
1. The directories for your results and errors files;
2. Optimization options;
3. The way to display the phases and the constituents.
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To open the Options window, double click on Options
in the tree view or select Options in the Menu bar.



Changing optimization options

In our case, we want a larger number of 
iterations. The default value is 5. Let’s put 
8 as the maximum number of iterations.

We can now start 
a new optimization
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To reopen the OptiSage: Results window and 
see the results of the previous optimization, 
select : Calculate > Optimization Results .



Convergent solution of the 2nd optimization

We have a convergent 
solution after 7 iterations
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Convergent solution of the 2nd optimization, saving the results

We save those results with: File > Save to file…

Your results are saved 
as an Excel file
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Optimization results, EXCEL file

Values of the optimized 
parameters (A1, A2, B1
and B2). See slide 9.15 
for more details.

Calculated values of the 
measured variables with the 
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measured variables with the 
optimized parameters. See 
slides 9.17 to 9.20 and 9.22 
for more details.
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The OptiSage window: general view

The Optimize Parameters frameTo abort an optimization: click on Kill in 
the menu bar or press the Kill button 
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The tree view frame The Groups frame
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The OptiSage window: the tree view frame
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Indicates that the results of the iteration #7 are viewed 
in the Optimized Parameters and the Groups frames.
To see the results of a previous iteration, click on it.
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The OptiSage window: Review of the Optimized Parameters

Remember (see slide 2.2) that OptiSage is used to optimize the parameters for the liquid Gibbs 
energy model (XS terms) and that a polynomial model for the Gibbs energy of the liquid was used:

G = (X1 G°1 + X2 G°2) + RT(X1 ln X1 + X2 ln X2) + GE

where GE = ∆H – TSE

Using the binary excess terms: ∆H = X1X2 (A1) + X1
2X2 (A2) and -SE = X1X2 (B1) + X1

2X2 (B2)

Hence: GE = X1X2 (A1 + B1T) + X1
2X2 (A2 + B2T)

Where A1, A2, B1 and B2 are the 4 parameters to be optimized and the subscript 1 and 2 are 
respectively for NaCl and SrCl2. We have 2 sets of parameters, one in X1X2 and one in X1

2X2.

OptiSage uses a more general form for the expressions of these excess energies, GE =ΣgE where:

χ 
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where the variable Yi is the equivalent molar fraction of component i.
See Solution slide show, section 6 for more details.
In our example, Yi = Xi which is the molar fraction.
LO is a polynomial having the general form: 
LO = A + BT + C(T lnT) + DT2 + ET3 + FT-1

In our example, LO has the form: LO = A + BT, where A and B are the parameters to optimize. 
Then,

2 2

2

E NaCl
(NaCl SrCl ) NaCl SrCl

NaCl SrCl

g Y Y LO
χ

χ χ−

 
=   + 

2 2

E
(NaCl SrCl ) NaCl SrClg Y Y LO− =

( )( )
( )

− = +

= +
2 2

2

E
(NaCl SrCl ) NaCl SrCl 2 2 NaCl

2
NaCl SrCl 2 2

g X X A B T X

X X A B T
( )− = +

2 2

E
(NaCl SrCl ) NaCl SrCl 1 1g X X A B T

and

and
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The OptiSage window: the Optimized Parameters frame

( )= +E 2 1 0 1g X X A T B T

( )− = +
2 2

E 1 1 0 1
(NaCl SrCl ) NaCl SrCl 1 1g X X A T B T
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( )− = +
2 2

E 2 1 0 1
(NaCl SrCl ) NaCl SrCl 2 2g X X A T B T

The Correction value is the difference between the New Value of the Optimized 
Parameter (obtained in this iteration) and it’s value obtained in the previous iteration.

The Uncertainty term is the error on the new value of the optimized parameter. 
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OptiSage main window: another view of the optimized parameters

First set of parameters:

( )− = +
2 2

E 1 1 0 1
(NaCl SrCl ) NaCl SrCl 1 1g X X A T B T

Second set of parameters:

( )− = +
2 2

E 2 1 0 1
(NaCl SrCl ) NaCl SrCl 2 2g X X A T B T

Return to the OptiSage main window to have another view of the optimized parameters.
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B2= 2.61633769403415

A2= -4190.64971130572

9.16

A 1= -1687.71359847888

B1 = -0.931550749032757



The OptiSage window: the Groups frame, group #1 tab

Measured value = Calculated Value + Correction

Color code for correction term C:
• Less than Err: black
• 1 × Err < C < 2 ×Err: blue
• 2 × Err < C < 3 ×Err: mauve
• More than 3 ×Err: red

www.factsage.comOptiSage

Calculated values of the measured 
variables with the optimized parameters. 
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The OptiSage window: the Groups frame, Group #2 tab

To view the results of a group, press on its tab
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These are the values entered previously (see slide 7.18)
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The OptiSage window: the Groups frame, Group #3 tab
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If you want to have a better view of your results, you can slide the barrier between 
the Experimental Conditions and the Measured Variable(s) spreadsheets. 
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The OptiSage window: the Groups frame, Group #4 tab
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If you want to remove a data before making another optimization, simply unselect it. 
Here, we remove experimental data point 3.
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Selection of a group of data

To select or unselect a group of data for an optimization, go to the OptiSage main
window menu bar and click on Groups > Select to open the Select Groups window.

www.factsage.comOptiSage

Here, we unselect Group #4
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The OptiSage window: the Groups frame, Group #5 tab
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A colored background indicates a warning
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Close OptiSage: Results window

Close the OptiSage: Results window to return to the main window
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Creation (Save data to databases) of an optimized Database

You can save your data to a database. 
In the OptiSage main window, select File > Save to databases to open 
the Save Phase Parameters to Database(s) dialog box.
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Saving Phase parameters to a database

2. Enter the file name

1. Browse or create your own folder

Folder Optimized DB

www.factsage.comOptiSage

3. Save your database.
In our example, we save a Solution database.

Note: You can save your parameters manually.

Folder Optimized DB
created in FactSage
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Generation of diagrams: comparison between experimental and calculated curves

The OptiSage module has no own calculational capabilities for 
thermodynamic properties or phase diagrams. From our newly created 
private database, Equilib and Phase Diagram can extract the data for 
appropriate calculations. To add your database to your list of databases 
available, please see slide 4.2.
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available, please see slide 4.2.

The graphical comparison between calculated and experimental data can 
be made by use of overlays in the Figure module. For the addition of 
experimental points into a calculated diagram please see the section 8 of 
the Slide Show on the Figure module.

11.0



o0.9

1 0

Comparison between experimental and calculated curves

Use the Equilib module to calculate activity curves for NaCl in the liquid phase ,
then overlay the experimental data from an appropriate FIG-file that was prepared
earlier.
Also use the Equilib module to calculate the enthalpy of mixing curve from the
new database. Make sure you use the correct „initial conditions“ in the reactants
screen:

<A> NaCl(liq, 894 °C) + <1-A> SrCl2(liq, 894 °C)
Thus only the mixing enthalpy is calculated and not the full enthalpy of the liquid.
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Comparison between experimental and calculated curves

Use the Phase Diagram module to generate a phase diagram with the 
appropriate temperature and composition range. Then overlay the FIG-file 
which contains the experimental points, the legend etc.
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Estimation of parameters with NOMAD (version 6.2+)

NOMAD is a Non-linear Optimiser with Mesh Adaptive Direct sear ch 
algorithm developed at GERAD (www.gerad.com/nomad).  It permits the 
minimisation of an objective function (like the sum of squared-errors in 
OptiSage) without involving any derivatives (black-box optimisation).
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NOMAD has been integrated in OptiSage from version 6.2 to give the user the option of 
estimating the selected optimized parameters from scratch (starting with 0 values).  Every 
iteration of NOMAD is usually quite fast, and several hundreds of iterations can be 
performed.  

At any point, the OptiSage user can kill the NOMAD window, and the latest best solution of 
estimated parameters is kept and transfered automatically to OptiSage, so the user can 
perform a Bayesian optimisation from this initial estimated set of parameters.



Estimation of parameters with NOMAD (version 6.2+)

The new features associated to NOMAD in OptiSage are:
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Estimation of parameters with NOMAD (version 6.2+)

The new features associated to NOMAD in OptiSage are:

· Calculate > Estimate Parameters with NOMAD
Run this option to have NOMAD performing an optimisation with 
its MESH ADAPTIVE DIRECT SEARCH algorithm.
The recommended procedure is to run a few hundred of 
iterations in NOMAD, kill the DOS-type window, and then use the 
current set of estimated parameters to run a complete 
Bayesian optimisation using Calculate > Optimize with Bayesian kill
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iterations Sum of Chi square



Estimation of parameters with NOMAD (version 6.2+)

The new features associated to NOMAD in OptiSage are:

· Options | Optimization...
1- The “max. number of iterations“ now applies to the standard 

Bayesian method.
2- NOMAD optimization options are “Max. number of black box 

evaluations (BBE)“ (in fact the max. number of iterations for 
NOMAD); the “Mesh size“ (up to 0.999 to cover the complete 
range of error of all parameters; or down to 0.001 if your 
starting estimates are excellent); “Display level“ is how much 
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starting estimates are excellent); “Display level“ is how much 
information will be displayed in the NOMAD DOS-type 

window (0 = none, 4 = all; 2 = recommended).



Estimation of parameters with NOMAD (version 6.2+)

The new features associated to NOMAD in OptiSage are:

· Help > About NOMAD...

Gives a link to the NOMAD Website (www.gerad.com/nomad) 
and information about its developpers.
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