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Use Compound to administer a private compound database, i.e. enter, edit or 
delete pure substance data in the database.
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The Compound module

Click on Compound in the 
main FactSage window to 
activate this module.
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Create a private Compound database, I
To create a read and write (r/w) database:

1. Click on «File» > 
«New Database…»

2. Select a directory and 
enter a filename

3.1
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Create a private Compound database, II

The status bar provides information on the database:
• location: C:\FACTSAGE\USERDATA\EXAMPLEBASE.CDB;
• compounds: 0 compound(s) (for now);
• version: 5.0;
• access: read/write.

3.2

The program automatically 
selects a four character 
nickname and adds the suffix 
-BASE to complete the name 
of your private database.  

Enter a short description of the 
database.
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Add a compound to the database

The following slides show how to enter the data for a new 
compound with three phases (solid, liquid, gas) into the
database.

MgCl2 is taken as the example. The data for this compound are 
summarized in the next slideslide. All entries are made using the 
values in this figure.

Two different methods of entering data are demonstrated:
1) H298, S298 and Cp with transition data for the high temperature 

phase (using data for solid and liquid MgCl2)

2) H298, S298 and Cp for the high temperature phase itself (using 
data for the gas).
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Compound data for 
MgCl2 are taken from 
this graph.
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o
S,298.15S = 79.0 J/mol·K

o
L,298.15S = 106.2 J/mol·K

o
G,298.15S = 194.1J/mol·K

Add a compound to the database, III

4.1
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Add a compound to the database, I

2. Type the chemical formula 
of the compound:   MgCl2, 
in the Formula input box

To enter a new compound, 
for example MgCl2, in 
EXAMBASE:

3. Select the function «Add
MgCl2 to EXAMBASE»
from the Edit Menu.

4. Select Input units
for the compound.

5. Press «OK»

1. Select EXAMBASE database

4.2
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Add a compound to the database, II
The database is now ready for new entries and modification of existing data.

The Real Stoichiometry input box appears if you have 
checked «Real stoichiometry» in the menu View.  This 
feature is for advanced users and applies to all phases 
of the compound (it does not apply to elements).

4.3

6. Enter:
• compound name;
• reference number(s);
• comments.
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1. Right click on MgCl2 and select «Add phase…» >
«Solid».

The Extended properties input 
box appears if you have 
checked «Extended properties»
in the menu View.  
This feature only 
applies to a given 
phase (S1).

Add a compound to the database: H298 and S298 for 1st phase, IV

Values of ΔH°(298.15) and S°(298.15) for 
S1 were obtained from the graph.

4.4

2. Enter the values for the enthalpy 
of formation ΔH°(298.15) and 
entropy S°(298.15). Compound
only takes these values when 
entering data for the first phase 
(S1).
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Add a compound to the database: extended properties, V

Compressibility expression:
2 1
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Add a compound to the database: Cp values for the 1st phase, VI

2. Enter the CP range from 298.15 K to 987 K
and the CP expression for MgCl2 S1

CP(S)= 79.1 + 5.94×10-3 T - 8.62×105 T-2 J/mol·K

1. Left click on Cp 6000 to 
open the input box «Cp 
expression for S1».

You can enter expressions for 
Cp and list those of H, S or G.

4.6
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Show data as H, S and G functions

Compound calculates automatically 
the expressions of H, S and G from 
your entry of the Cp expression.

The data colored in gray indicates that 
you can not edit these expressions.

5.1
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Edit the Gibbs Energy function
Compound lets you edit the Gibbs energy function by clicking
the Edit button to open the G Input form. 

The data colored in black indicates 
that you can edit these expressions.

6.1

Here the Gibbs energy coefficients are 
used instead of H, S and Cp data.
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Entering phase transition data:  the liquid phase

The next three slides illustrate how to enter a new phase (here 
the liquid) if the data for the phase transition between the 
previous phase (here the solid) and the new phase, i.e. ΔH and 
Ttrans, as well as the Cp data of the new phase are available.
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Entering phase transition data:  the liquid phase, I
1. Right click on « » to open a pop-up menu. 2. Point the arrow to «Add 

phase…» and select 
«Liquid» from the sub 
menu with a click.

3. Compound proposes two ways 
to enter the data:

•either you enter the enthalpy 
of formation ΔH°(298.15) and
entropy S°(298.15) for phase 
L1 and the entry is flagged by 
the icon

•or you enter the enthalpy
and temperature of 
transformation and the entry 
is flagged by the icon

7.1
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Entering phase transition data: the liquid phase, II

4. Click on Cp 6000 to open the 
box «Cp expression for L1»

3.(continued)
Entering the enthalpy
and temperature of
transformation.

The Extended properties input box appears if you 
have checked «Extended properties» in the menu 
View. This feature applies to a phase exclusively.

7.2

5. Click on L1 to open the box 
of Extended properties
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Entering phase transition data: Cp coefficients of the liquid phase, III

Compound calculates automatically the values of ΔH°L, 298.15 and 
S°L, 298.15 (these values are the same as those in the graphthe graph).

5. Enter the CP range from 298.15 K to 1691 K and the CP expression
for MgCl2 liquid (slide #6):  CP(L)= 92.5J/mol·K

7.3
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Entering a new phase with H298, S298 and Cp:  the gaseous phase

The following three slides show how an additional phase (here 
the gas) is entered for which H298, S298 and Cp are known.

The entry of extended data for the non-ideal behaviour of the gas 
according to the Tsonopoulos method is also shown.
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Entering a new phase with H298, S298 and Cp:  the gaseous phase, I

2. Point the arrow to «Add phase…» and select 
«Gas» from the sub menu with a click.

1. Right click on « »
to open a pop-up menu.

8.1
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Entering a new phase with H298, S298 and Cp:  the gaseous phase, II

3. Enter the values for the 
enthalpy of formation
ΔH°(298.15) gas and 
the entropy S°(298.15) 
gas.  (See slide 4.3slide 4.3)

The Extended properties input box appears if you 
have checked «Extended properties» in the menu 
View.  This feature applies to a phase exclusively.

8.2

4. Click on Cp 6000 to open the 
box «Cp expression for L1»
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Entering a new phase with H298, S298 and Cp:  extended properties for the gas, III

B is estimated for pure gases and mixtures by the Tsonopoulos*
method from Pc, Tc, and Ω (omega, the acentric factor) for the pure 
gases.  Gases are treated as non-polar.  For ideal gases, the value 
of B is zero.

The truncated virial equation of state is employed to treat real gases:

PV BP=1+
RT RT

Tc Pc Vc

Ω μ

* «An Empirical Correlation of Second Virial Coefficients» by C. Tsonopoulos, 
AIChE Journal, vol. 20, No 2, pp. 263-271, 1974.

8.3
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Finishing and saving the entry

The next slide shows how the last data item for MgCl2, the Cp
coefficient of the gas phase, is entered

and 

the complete dataset is saved in the private database.  
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Finishing and saving the entry, I
5. Enter the CP range from 

298.15 K to 6000 K and 
the CP expression for 
MgCl2 gas (slide 4.3slide 4.3):  
CP(G)= 95 J/mol·K

9.1

6. Press on the Save button (     ) to complete your entry for this 
compound (You can also select «Save MgCl2 to EXAMBASE»
from the menu Edit).  Now your database contains 1 compound.  
The fading of the compound icon (from           to           ) 
indicates that your data are saved.
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Displaying data with ViewData, I

2. Click on the Cp(T) and 
Phases tabs to display 
the compound data.

1. Click on «ViewData» in the menu bar to open the 
ViewData application.

10.1
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Displaying data with Compound, II
1. To display compound data, for example MgSO4 in FACTBASE, 

enter MgSO4 in the Formula input box.

2. Expand the tree structure for FACTBASE and search through the MgSO4
branches to list its data.

3. Move the pointer over the 
reference text box to view 
the detailed bibliography

10.2

“Thermochemical Properties of Inorganic Substances”,
I. Barin, O. Knacke, and O. Kubaschewski,
Springer-Verlag, Berlin, 1977.
(for non-aqueous species)
appended to:
“Handbook of Thermochemical Data for Compounds and Aqueous Species”,
H.E. Barner and R.V. Scheuerman,
Wiley-Interscience, New York, 1978.
(for aqueous species)
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Displaying data for a list of products, III
1. Select «List of 

products» in 
the View menu. 

3. Expand the tree structure to see the list of 
compounds containing O, S and/or Mg.

2. Enter a chemical formula of a compound ( ) 
or the elements ( ) of interest in the Formula 
input box.  For example O, S and Mg.

10.3
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Transferring data between databases

Data for single compounds can be easily transferred between 
databases.

This is useful if you want to investigate how data changes for a
compound in a read-only database affect results in calculations. 
Simply generate your own private database and copy the desired 
compound(s) from the read-only database over to your private 
database.

There are two ways to do this as shown in the following slides.
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Transferring data between databases, I
1. Select the compound of interest in its database.  

For example, click on MgSO4 in FACTBASE.

4. Select «Paste MgSO4» from the Edit menu.

2. Select «Copy» from 
the Edit menu.

11.1

3. Select the destination database.  
Here, EXAMBASE.



www.factsage.comCompound 11.2

Transferring data between databases, II

Simply drag-and-drop MgSO4
from FACTBASE to EXAMBASE.

Note that the MgSO4 data retrieved from the 
read only (r) FACTBASE database are shown 
in gray color.

Note that the MgSO4 data retrieved from the 
read and write (r/w) EXAMBASE database are 
shown in black color and can be edited.
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Editing a read and write (r/w) database.
You expand and reduce the 
extent of the tree structure of the 
databases by left-clicking on 
the box at the right of an icon.

12.1

Data in a read/write database may be added, 
removed or modified. Here the Cp range for the 
solid (S1) phase of MgSO4 in the r/w
EXAMBASE database is edited.
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The Erase, Remove and Clear commands

The Erase, Remove and Clear commands

• erase (delete) single compounds from a particular database

• remove single compounds from an edit list

• clear complete edit lists.

NOTE: The Remove and Clear commands do not interfer with 
the contents of databases and can be applied to all 
databases.
The Erase command only works for read/write 
databases.



www.factsage.comCompound

The Erase, Remove and Clear commands, I
1. Select the compound you want to delete

(say, CO2) from the r/w database.

13.1

3. Confirm your intention 
to erase data

Now the database EXAMBASE
contains only 2 (= 3 - 1) compounds.

2. Go to the Edit menu and select 
Erase CO2 from EXAMBASE.
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The Erase, Remove and Clear commands, II
1. Select the compound you want to remove

(say, CO2) from the tree view list.

13.2

2. Go to the Edit menu and select
Remove CO2 from list.

The compound CO2 is not 
shown in the tree view but
the database EXAMBASE
still contains 3 compounds.
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The Erase, Remove and Clear commands, III
To remove all the compounds from all the lists (you are not deleting the compounds 
from the databases) in the treeview (i.e. to clear the treeview): 

Go to the Edit menu and select «Clear list of compounds».You
can also press the button «Clear list of compounds» in the toolbar.

13.3

The compounds are not 
shown in the tree view but
the database EXAMBASE
still contains 3 compounds.
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The «Mixer» feature

The «Mixer » feature permits the generation of new compound 
data using «simple algebra» on the data of already stored 
compounds.

The first example shows how the known data for Na2O and Al2O3 
are used in a Neumann-Kopp type sum to generate data for the 
unknown compound NaAlO4. The scale down command is used 
to come to the desired formula.

Alternatively, the use of the scale up command is shown for the 
formula Na3Al3O6.

The second example shows how the known data for Li3N, Li and 
Na are used to generate data for the unknown compound Na3N
using Li3N + 3Na - 3Li = Na3N.
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The «Mixer» feature: Example 1, I
The «Mixer» option enables you to create and store compound data on a new 
(possibly hypothetical) species by mixing data of existing species. For example, 
new data on NaAlO2 via the reaction: ½ Na2O(s1) + ½ Al2O3(s1)→ NaAlO2(s1). 

1.  Open the database containing the data on Na2O
and Al2O3 and expand the treeview to list phases. 2.  Click on Tools > Mixer…

14.1
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The «Mixer» feature: Example 1, II

This stores the new compound Al2Na2O4 in the database. To store NaAlO2
you need to use the «Scale Down» command in the Tools menu.

3. Drag and drop the phases to the Compound
Mixer window or use the Add Phase button. 

Remove the selected phase

Remove all phases

Add or substract the selected phase

Paste the new compound to a read and write database.

14.2
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The «Mixer» feature: Example 1, III

To scale down a compound:

1. Save your compound in a r/w
database:

A. Select a r/w database.
B. Paste your compound.

2. Go to the Tools menu and
select «Scale Down».

Now you have the scaled down compound AlNaO2 in your r/w database.

14.3
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The «Mixer» feature: Example 1, IV
On the other hand, if you want the thermodynamic properties of
Na3Al3O6, which is 3 times AlNaO2, use the Scale Up command. 

1. Select the compound you want to scale up

2. Go to the Tools menu and select Scale Up…

3. Enter the scale factor in the
Scaling up compound
dialog box and press «OK».

Now you have the compound 
Al3Na3O6 in your r/w database

14.4
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The «Mixer» feature: Example 2
This example shows how to create new data on Li3N via the synthesis of: 
Li3N + 3Na - 3Li.

1. Drag and drop the Li3N, Na and Li phases to Compound Mixer.

2. Click on the Add Phase button to add 3 Na and 3 Li. 

3. Press the Add and Substract
button to substract 3 Li from
the reactants. This create
Na3N as product.

14.5
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You may use data of an already stored compound as a template to enter data for a new 
compound. Here known data for MgCl2 is used to generate new data for CaCl2 by using
the Copy data to new Compound option in the Tools menu.

Using known data as template: «Copy data to new Compound», I

1. Select MgCl2 in EXAMBASE. 

2. In the Tools menu, select 
Copy data to new Compound

15.1
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Using known data as template, II

4. You now have the
CaCl2 template.

3. In the dialog box, enter the new 
compound CaCl2 and press «OK». 

15.2
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Changing Units of Energy and Pressure

Click on menu Units.

16.1

Changing Pressure units 
from atmosphere to bar.

Changing the energy units will affect H, S and Cp as well as H, S and G 
functions. Changing the pressure units will ONLY influence the value of S298 of 
gas species, the first coefficient of the S function, and the second coefficient of 
the G function.

Changing Energy units 
from Joules to calories.
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Entering Fuel consisting of hydrocarbons and sulfur, I
1. Click on «Tools» > 
«Fuel»

Compound 17.1

2. Select  Solid
or Liquid fuel

3. Select checkbox Net (Net Heating Value) if 
water in products is gaseous, or unselect
checkbox Net (Gross Heating Value) if water 
in products is liquid. 
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Entering Fuel consisting of hydrocarbons and sulfur, II

Compound 17.2

4. Enter the Heating Value in BTU/lb – this 
assumes perfect combustion where products 
are solely CO2, H2O and SO2.

6. Click evaluate to display the 
properties of the fuel.

5. Enter the weight composition of C, 
H and S of the fuel. Note the 
calculated %wt and %atom.

7. Press OK when finished.

8. Edit the comments.

9. Click to save the new 
compound.
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